Рейтинг@Mail.ru

Наши друзья и партнеры

купить дешевый 
компьютер родом из Dhgate.com




Книги по Linux (с отзывами читателей)

Библиотека сайта rus-linux.net

На главную -> MyLDP -> Электронные книги по ОС Linux
Beyond Linux From Scratch. Version 2011-12-30
Назад 33. Основные пакеты GNOME. Платформа Вперед

Пакет libgnomeui-2.24.3

Знакомимся с пакетом libgnomeui

В пакете libgnomeui находятся библиотеки libgnomeui.

Известно, что пакет правильно собирается и работает на платформе LFS-6.5.

Информация о пакете

Зависимости пакета libgnomeui

Обязательные

libbonoboui-2.24.3, libgnome-keyring-2.30.1 и Xorg Libraries

Необязательные

libjpeg-8c, EsounD-0.2.41 и GTK-Doc-1.18

Замечания для пользователей: http://wiki.linuxfromscratch.org/blfs/wiki/libgnomeui

Установка пакета libgnomeui

Установите пакет libgnomeui с помощью запуска следующих команд:

./configure --prefix=$(pkg-config --variable=prefix ORBit-2.0) \
            --libexecdir=$(pkg-config \
                --variable=prefix ORBit-2.0)/lib/libgnomeui &&
make

В этом пакете набор тестов отсутствует.

Теперь в роли пользователя root выполните:

make install

Пояснение команд

--prefix=$(pkg-config --variable=prefix ORBit-2.0): Установка префикса с помощью этого параметра, а не с помощью $GNOME_PREFIX будет гарантировать, что префикс будет установлен в соответствие со средой окружения и пакет будет установлен в нужном месте.

--libexecdir=$(pkg-config --variable=prefix ORBit-2.0)/lib/libgnomeui: Этот параметр указывает, что файлы libexec будут установлены в более правильный директорий $GNOME_PREFIX/lib/libgnomeui, а не в директорий $GNOME_PREFIX/libexec.

--with-kde-datadir=$KDE_PREFIX/share: Используйте этот параметр, если KDE установлен не в директорий /usr.

--enable-gtk-doc: Используйте этот параметр, если установлен пакет GTK-Doc и вы хотите пересобрать и установить документацию по API.

Конфигурирование пакета libgnomeui

Подробнее о конфигурировании

Некоторые приложения не могут правильно найти библиотеку интерфейса libglade, установленную с помощью libgnomeui. Обойти эту проблему можно с помощью инициализации переменной окружения, которая указывает место, где расположена библиотека. Добавьте следующую строку в общесистемный файл /etc/profile или в персональный файл пользователя ~/.profile или ~/.bashrc:

export LIBGLADE_MODULE_PATH=$GNOME_PREFIX/lib/libglade/2.0

Описание пакета

Установленные программы: Нет

Установленные библиотеки: libgnomeui-2.{so,a} и библиотека libgnome.{so,a} Glade

Установленные директории: $GNOME_PREFIX/{include/libgnomeui-2.0/libgnomeui, share/gtk-doc/html/libgnomeui}

Краткое описание

libgnomeui-2.{so,a}

библиотеки GNOME, связанные с графическим интерфейсом

Перевод сделан с варианта оригинала, датированного 2010-08-16 09:51:51 +0000


Предыдущий раздел: Оглавление Следующий раздел:
Пакет libbonoboui-2.24.3   Пакет libgnome-keyring-2.30.1

Если вам понравилась статья, поделитесь ею с друзьями: