Рейтинг@Mail.ru
[Войти] [Зарегистрироваться]

Наши друзья и партнеры

UnixForum




Lines Club

Ищем достойных соперников.

Книги по Linux (с отзывами читателей)

Библиотека сайта или "Мой Linux Documentation Project"

На главную -> MyLDP -> Электронные книги по ОС Linux
Beyond Linux From Scratch. Version 2011-12-30
Назад 24. Библиотеки системы X Вперед

Пакет notification-daemon-0.4.0

Знакомимся с пакетом notification-daemon

Пакет notification-daemon является демоном, которые отображает пассивно всплывающие уведомления.

Информация о пакете

Зависимости пакета notification-daemon

Обязательные

GConf-2.28.1, libglade-2.6.4, libnotify-0.4.5, libsexy-0.1.11 и libwnck-2.30.2

Необязательные

GStreamer-0.10.25

Замечания для пользователей: http://wiki.linuxfromscratch.org/blfs/wiki/notification-daemon

Установка пакета notification-daemon

Установите пакет notification-daemon с помощью следующих команд:

./configure --prefix=/usr \
            --libexecdir=/usr/lib/notification-daemon-1.0 \
            --with-gconf-schema-file-dir=/etc/gnome/2.30.2/gconf/schemas &&
make

В этом пакете набор тестов отсутствует.

Теперь в роли пользователя root выполните:

make install

Пояснение команд

--libexecdir=/usr/lib/notification-daemon-1.0: Этот параметр используется для того, чтобы внутренние программы, осуществляющие поддержку работы notification-daemon, устанавливались в правильный директорий /usr/lib/notification-daemon-1.0, а не в директорий /usr/libexec.

--with-gconf-schema-file-dir=/etc/gnome/2.30.2/gconf/schemas: Этот параметр используется для того, чтобы файлы схем GConf устанавливались в существующую базу данных.

Описание пакета

Установленные программы: notification-properties и notification-daemon

Установленные библиотеки: libstandard.{so,a}

Установленные директории: /usr/{lib/notification-daemon-1.0/engines, share/notification-daemon}

Краткое описание

notification-properties

инструментальное средство, предназначенное для доступа к свойствами демона уведомлений notification-daemon

notification-daemon

сам демон

Перевод сделан с варианта оригинала, датированного 2010-05-25 12:53:25 +0000


Предыдущий раздел: Оглавление Следующий раздел:
Пакет libnotify-0.4.5   Пакет gtk-vnc-0.3.10


Эта статья еще не оценивалась
Вы сможете оценить статью и оставить комментарий, если войдете или зарегистрируетесь.
Только зарегистрированные пользователи могут оценивать и комментировать статьи.

Комментарии отсутствуют