Рейтинг@Mail.ru

Наши друзья и партнеры

UnixForum
купить дешевый 
компьютер родом из Dhgate.com




Библиотека сайта rus-linux.net

На главную -> MyLDP -> Электронные книги по ОС Linux
Beyond Linux From Scratch. Version 2011-12-30
Назад 39. Мультимедийные библиотеки и драйверы Вперед

Пакет GStreamer Ugly Plug-ins-0.10.10

Знакомимся с пакетом GStreamer Ugly Plug-ins

Пакет GStreamer Ugly Plug-ins представляет собой набор плагинов, которые, по словам разработчиков Gstreamer, имеют качественный код и правильную функциональность, но с их распространением могут возникать проблемы. Лицензия плагинов или библиотек поддержки может оказаться не такой, какой бы хотели пользоваться разработчики Gstreamer. Общеизвестно, что из-за кода могут возникать патентные проблемы. Смотрите также пакеты GStreamer Good Plug-ins-0.10.17, GStreamer Bad Plug-ins и GStreamer FFmpeg plug-in.

Информация о пакете

  • Загрузка (HTTP): http://gstreamer.freedesktop.org/src/gst-plugins-ugly/gst-plugins-ugly-0.10.10.tar.bz2
  • Контрольная сумма MD5: 031205d5599fce73fc36766f928b2515
  • Размер загружаемого пакета: 917 KB
  • Оценочный размер требуемого дискового пространства: обычно 16 MB (зависит от того, какие зависимости установлены)
  • Оценочное время сборки: обычно 0,3 SBU

Зависимости пакета GStreamer Ugly Plug-ins

Обязательные

GStreamer Base Plug-ins-0.10.25

Необязательные

LAME-3.99.3, Liba52-0.7.4, libamrnb, libdvdnav, Libdvdread-0.9.7, libmad-0.15.1blibid3tag), libmpeg2-0.5.1>, libsidplay и libcdio

Необязательные, требуемые для регрессионного тестирования

Чтобы запустить тесты, вам необходимо скомпилировать gstreamer вместе с libcheck, и, при желании, вы можете использовать пакет Valgrind.

Необязательные (требуемые для пересборки документации по API)

GTK-Doc-1.18 и Python-2.7.2 (компилируется совместно с парсером XML, таким как Expat-2.0.1).

Замечания для пользователей: http://wiki.linuxfromscratch.org/blfs/wiki/gst-plugins-ugly

Установка пакета GStreamer Ugly Plug-ins

Установите пакет GStreamer Ugly Plug-ins с помощью следующих команд:

./configure --prefix=/usr &&
make

Чтобы запустить регрессионные юнит тесты, выполните команду make check.

Теперь в роли пользователя root выполните:

make install

Если вы не передавали параметр --enable-gtk-doc в скрипт configure, т. е. заново не собирали документацию по API, а хотите установить предварительно собранную документацию, то в роли пользователя root выполните следующую команду:

make -C docs/plugins install-data

Пояснение команды

--disable-static: Предотвращает сборку статических библиотек.

Описание пакета

Установленные программы: Нет

Установленные библиотеки: Несколько плагинов GStreamer

Установленные директории: /usr/share/gtk-doc/html/gst-plugins-ugly-plugins-0.10

Перевод сделан с варианта оригинала, датированного 2009-01-20 22:34:30 +0000


Предыдущий раздел: Оглавление Следующий раздел:
Пакет GStreamer Good Plug-ins-0.10.17   Пакет Farsight2-0.0.12

Если вам понравилась статья, поделитесь ею с друзьями: