Рейтинг@Mail.ru
[Войти] [Зарегистрироваться]

Наши друзья и партнеры

UnixForum
Беспроводные выключатели nooLite купить дешевый 
компьютер родом из Dhgate.com

Lines Club

Ищем достойных соперников.

Библиотека сайта или "Мой Linux Documentation Project"

На главную -> MyLDP -> Электронные книги по ОС Linux
Beyond Linux From Scratch. Version 2011-12-30
Назад 34. Дополнительные пакеты GNOME. Утилиты Вперед

Пакет Empathy-2.30.2

Знакомимся с пакетом Empathy

Пакет Empathy представляет собой программу обмена сообщения, которая позволяет использовать текстовый, голосовой и видео-чат, а также передачу файлов с использованием различных протоколов.

Известно, что этот пакет собирается на платформе LFS 6.5, но он не тестировался.

Информация о пакете

Зависимости пакета Empathy

Обязательные

Evolution Data Server-2.30.2.1, GNOME Doc Utils-0.20.2, libcanberra-0.18, libgnome-keyring-2.30.1, libnotify-0.4.5, libunique-1.1.2,telepathy-farsight-0.0.4 и Which-2.20

Необязательные

Check, clutter-gtk-0.10.4, ConnMan, enchant-1.6.0, GeoClue, GNOME Panel-2.30.2, GTK-Doc-1.18, ISO Codes-3.30, libchamplain, NetworkManager, PyGTK-2.17.0, Rarian-0.8.1, Valgrind и WebKitGTK+-1.6.1

Необязательные (протоколы)

telepathy-butterfly (MSN), telepathy-gabble (Jabber, Google Talk, XMPP), telepathy-idle (IRC), telepathy-haze (AIM, ICQ, Yahoo!), telepathy-salut (локальные сети, использующие вызовы "Bonjour" и iChat) и telepathy-sofiasip (SIP)

Замечания для пользователей: http://wiki.linuxfromscratch.org/blfs/wiki/empathy

Установка пакета Empathy

Установите пакет Empathy с помощью следующих команд:

./configure --prefix=$(pkg-config --variable=prefix ORBit-2.0) \
            --sysconfdir=/etc/gnome/2.30.2 \
            --libexecdir=$(pkg-config \
                --variable=prefix ORBit-2.0)/lib/empathy &&
make

В этом пакете набор тестов отсутствует.

Теперь в роли пользователя root выполните:

make install

Пояснение команд

--prefix=$(pkg-config --variable=prefix ORBit-2.0): Установка префикса с помощью этого параметра, а не с помощью $GNOME_PREFIX будет гарантировать, что префикс будет установлен в соответствие со средой окружения и пакет будет установлен в нужном месте.

--sysconfdir=/etc/gnome/2.30.2: Этот параметр указывает, что конфигурационные файлы будут установлены в директорий /etc/gnome/2.30.2, а не в директорий .$GNOME_PREFIX/etc. Кроме того (если это требуется), этот параметр гарантирует, что будет правильно обновлена база данных GConf-2.

--libexecdir=$(pkg-config --variable=prefix ORBit-2.0)/lib/empathy: Этот параметр указывает, что внутренние программы, поддерживающие работу Empathy , будут установлены в более правильный директорий $GNOME_PREFIX/lib/empathy, а не в директорий $GNOME_PREFIX/libexec/empathy.

--enable-gtk-doc: Используйте этот параметр, если установлен пакет GTK-Doc и вы хотите пересобрать и установить документацию по API.

Описание пакета

Установленные программы: empathy, empathy-accounts и empathy-debugger

Установленные библиотеки: libnstempathy.{so,a}

Установленные директории: $GNOME_PREFIX/share/{empathy/icons/hicolor/{16x16/{actions, apps,status},22x22/{actions,apps,status},24x24/{actions,apps,status}, 32x32/{apps,status},48x48/{apps,status},scalable/{apps,status}}, gnome/help/empathy/*,telepathy/clients}

Краткое описание

empathy

клиент GNOME для передачи мгновенных сообщений с использованием Telepathy

libnstempathy.{so,a}

плагин nautilus-sendto, использующий Empathy

Перевод сделан с варианта оригинала, датированного 2010-08-22 03:25:44 +0000


Предыдущий раздел: Оглавление Следующий раздел:
Пакет Ekiga-3.2.7   Пакет EOG-2.30.2


Эта статья еще не оценивалась
Вы сможете оценить статью и оставить комментарий, если войдете или зарегистрируетесь.
Только зарегистрированные пользователи могут оценивать и комментировать статьи.

Комментарии отсутствуют